安装PostgreSQL15报错:Requires: llvm-toolset-7-clang >= 4.0.1

发布时间:2023-11-23 22:40:17,浏览457次

问题描述:

安装postgresql15-devel时提示需要依赖

Error: Package: postgresql15-devel-15.5-1PGDG.rhel7.x86_64 (pgdg15)
           Requires: llvm-toolset-7-clang >= 4.0.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

解决办法:

安装centos-release-scl-rh包即可:

yum install centos-release-scl-rh

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Downloading packages:
centos-release-scl-rh-2-3.el7.centos.noarch.rpm            |  12 kB   00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : centos-release-scl-rh-2-3.el7.centos.noarch                  1/1 
  Verifying  : centos-release-scl-rh-2-3.el7.centos.noarch                  1/1 

Installed:
  centos-release-scl-rh.noarch 0:2-3.el7.centos                                 

Complete!
评论